Any add-on that links with youtube gives error

    This site uses cookies. By continuing to browse this site, you are agreeing to our use of cookies. More details

    • Any add-on that links with youtube gives error

      When trying to play add-ons such as lets say Crime tube or Bob Ross or most documentaries that links to youtube, I keep getting a youtube error...Bad request Youtube API has not been configured... Only started getting this when I upgraded to kodi jarvis... Does anyone else have this problem? Is there a fix just using the firestick without a pc?
      ?(
    • tandv73 wrote:

      When trying to play add-ons such as lets say Crime tube or Bob Ross or most documentaries that links to youtube, I keep getting a youtube error...Bad request Youtube API has not been configured... Only started getting this when I upgraded to kodi jarvis... Does anyone else have this problem? Is there a fix just using the firestick without a pc?
      ?(
      I know it's been a few weeks since you posted this but I just had the same problem and solved it today. I am responding to help future searchers.

      The problem is that Youtube has changed their API and you have an old version of the YouTube add-on. The developers haven't gotten a repository approved by the XBMC Foundation (their working on it), so it's a bit tricky trying to get an update.

      I installed from the MTLFREETV repo as described in this video: youtube.com/watch?v=qAsBB7lOLgs

      Youtube is now working again for me.